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LibreOffice

LibreOffice is a powerful and free office suite, used by millions of people around the world. Its clean 

interface and feature-rich tools help you unleash your creativity and enhance your productivity. 

LibreOffice includes several applications that make it the most versatile Free and Open Source office 

suite on the market: Writer (word processing), Calc (spreadsheets), Impress (presentations), Draw 

(vector graphics and flowcharts), Base (databases), and Math (formula editing).

This tutorial was written with LibreOffice Writer’s libreoffice.org
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Welcome to our first session.1

A word processor is a computer program used for the production of any sort of printable material.

Word Processing 

Word processing is the creation of documents using a word processor.

The Word Processor we are using is part of the LibreOffice Suite. It is called simply Writer

Before we start we first need to know how to launch (Start) Writer. The first task is to open Writer. The easiest way 

to do this is via the start menu. So click on the Raspberry button, look for Office then LibreOffice Writer and click on 

the icon. 

The Writer Screen
The main features are:

1 You will need the files Tips and Tricks and Spelling downloadable (Free) from giakonda.org.uk if you want to complete the 
exercises. 
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The Title bar. This is the blue bar across the top of the screen. It is called the title bar because it contains the title of 

the application you are running, in this case Writer and also the title of the document you are editing. If you have 

just started using Writer the document title is Untitled 1. Usually you will save this document with a new name 

before you start to write it. The title bar will then contain the file name you have given to the document.

On the right of the title bar are the Control Buttons, Minimise, Restore down/Maximise and Close. These allow you 

to control the size of the Writer window and to close it all together.

The additional x below the three other symbols simply closes the current open document

The Ribbon The ribbon is made up of a set of tools that each, in turn, effect some aspect of Word processing. 

The ribbon is an improvement alternative to drop down menus. As you work with different objects , images, tables 

etc. you will notice the ribbon tools change to the tools appropriate to the object you are working on. 

The Task panes (on the Right in the screen above) There are task panes that appear from time to time to help you 

work through a process e.g. mail-merge.
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The Ruler is useful to position text accurately

For doing accurate work, particularly with Word-processing tabs, it can be essential to see the distance between 

points on your document. The Ruler provides the means to do this. If you don't have the ruler displayed then click on

the View Tab, look for the Ruler check box and place a tick in it by clicking on it. It can also be activated from the 

ruler icon at the top of the scroll bar. If you need it you can also use the vertical ruler
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The Status Bar At the bottom of your document is the Status Bar. This is where you find current details of your 

work.

It contains information such as the current page and the number of pages in your document and the number of 

words you have typed so far. On the right of the Status Bar are the various page views (Single Page  view, Multi-page

view, Book view) that are available. The Zoom Bar is used to increase and decrease the size of your page.

Single page view Multi page view Book view Zoom bar %Zoom

Keyboard shortcuts.

Keyboard short-cuts allow you to do things more quickly

If you are the sort of person who likes to use a keyboard rather than a mouse then you can do so by using the CTRL 

key and pressing the appropriate key. For example pressing the CTRL key followed by the B key gives you Bold text. 

This is usually written CTRL+b

afp://howard@Swansea.local/GKSS/GKSS Training/Writer/LibreOffice Writer ecdl course notes 1v4.odt
Page 8 of 49



GiaKonda Solar Schools

Getting Help
You can get help by using the help drop down menu on the top right of the tool bar or by pressing the function key 

F1 (You have to download and install the built in Help from LibreOffice.org).
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Editing Documents

One of the main advantages of any word processing package is being able to change text by moving it around or 

copying it between documents.

Deleting and Moving text 

If you don’t want to use the text you have simply select it (by holding down the left mouse button and at the same 

time carefully swiping the mouse pointer over it) and press the Delete or Del Key.

You can delete words to the left of the cursor by holding down CTRL and pressing BACKSPACE.

Should you want to use the text in another place then you can make use of the Clipboard.

This is a feature of most applications. It lets you move things from one place to another even between different 

applications.

The general term for this work is Cut and Paste though it also includes Copy

Cut, Copy and Paste are on the ribbon.

Cut deletes the selected items and places them in the clipboard.

Paste places the contents of the clipboard in the new location.

Copy places the selected items in the clipboard but does not delete them.

The keyboard short-cuts for this are:

Select  Shift and the arrow keys to select text. 

Cut Ctrl +X (think of the x as a scissors) to cut the selected text.

Paste Ctrl + V (moVe) to paste the object in a new location.

Copy Ctrl + C to Copy the selected text.
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If you select any text and right-click, Cut, Copy and Paste are the top options in the Drop-down menu.

Note: The paintbrush is the Format painter NOT the Paste command

 Open the document Tips and Tricks.odt and place the bullet points in their correct locations.

 Once completed save the document as Tips and Tricks completed.odt



Note: Often Cutting and Pasting can cause a few issues. Remember you can always use the Undo function

to go back to your original work
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Drag and Drop

This is a quick alternative to using Cut and Paste.

 Select the text to be moved(by holding down the left mouse button and at the same time swiping the mouse 

pointer over it)

 Place the mouse pointer over the text, now with a colour background  

 Keep holding the left mouse button down, continuously, and Drag the pointer to the new location for the 

text

 A grey vertical line and a grey box will show where the text will appear in the document

 Release the mouse button to Drop the text in its new position.

Undo and Redo
You will find these essential features on the Ribbon.

Undo  (CTRL + Z) Choose this if you make a mistake and want to undo it, 

Redo  (CTRL + Y) Lets you repeat the last action you did or cancel the last thing you undid. 

Using Cut, Copy and Paste

 Open document word-processing tips.odt

 Using cut, copy, paste, drag and drop, rearrange the document so the paragraphs are in numbered order

 Headings will be default until you change the settings. Make a note of what they are.

 Make the body text 12pt.

Basic Formatting
Bold, Italic, Underline, Superscript, Highlighting and Colour of text are all found in the ribbon.

In the space available write down what each tool does. Don’t forget you can hover over each to see. You could also 

make a note of the keyboard short-cuts.
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Find and Replace
Editing documents often requires searching for particular words. It is easy to miss words in a long document. Writer 

has a Find and Replace function that lets you search for some text and even replace it with different text. 

Find and Replace are on the Editing drop down menu.

Finding
Select Find from the Edit drop-down menu.

A pane will open up to the left of the document. Put the word you are 

searching for in the search area.

Replacing
Replace is very similar to Find but it gives you the option of changing 

the word searched for.

 Open the document word-processing.odt

 Use Replace to change all instances of dialog to dialogue

 Use Replace All to change all instances of the word tips to 

advice

 Check the final paragraph of the document to see the dangers 

of using Replace All unless you are sure the word you are 

replacing is unique

 Use Undo to change advice back into tips

 Click More to see additional options

 Use the Format Option to search for text in italics.
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Paragraph Formatting
A paragraph is all the text that is entered between each press of the ENTER key. When you type with Writer you do 

not need to press the enter key when you reach the end of a line. Writer takes care of that for you.

The basic functions of changing the paragraph are found under the Format tab. 

Select Paragraph to display the Paragraph dialogue box
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Bullets and Numbering
Creating Numbered or Bulleted Lists as You Type

LibreOffice can automatically apply numbering or bullets as you type.

To Enable Automatic Numbering and Bulleting

Choose Tools > AutoCorrect > AutoCorrect Options, click the Options tab, and then select Bulleted and numbered 

lists.

Choose Tools > AutoCorrect, and ensure that While Typing is selected.

Note: The automatic numbering option is only applied to paragraphs that are formatted with the "Default", "Text 

body", or "Text body indent" paragraph style.
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To Create a Numbered or Bulleted List While You Type

Type 1., i., or I. to start a numbered list. Type * or - to start a bulleted list. You can also type a right parenthesis after 

the number instead of a period , for example, 1) or i).

Enter a space, type your text, and then press Enter. The new paragraph automatically receives the next number or 

bullet.

Press Enter again to finish the list.

You can start a numbered list with any number.

 Try this by typing a bulleted list with the bullet points 

Line one

Line two 

Line three

 Open the document Tips and Tricks No Bullets.odt.

 Under Word-processing guidelines, for paragraphs three to seven add bullets of your choice. You can always 

undo any changes and retry with a different bullet.

 Under Word-processing tips, for paragraphs two to six try using numbered lists. Again use undo to reset out 

your choices.

 Save the document as “Tips and Tricks bulleted.odt” in a format readable by someone who has Word 2003. 

Don’t close the document.
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Paragraph Dialogue Box

Additional Paragraph Formatting can be found by launching the Paragraph Group dialogue box from the Format 

drop-down box. Indents & Spacing and Borders are shown here below.

Indents & Spacing

 Create a new document and write a short paragraph about something you are interested in.

 Now open the paragraph dialogue box and change the Spacing Below to 0.2 pt. Observe the effect. Similarly 

change the Line spacing to different values and again observe the effect.

 Change the Indentation to First line indent 1.27 cm
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Borders

Borders and Shading can be used to emphasise a section of work as here

 Using the document, Tips and Tricks Bulleted.odt, add a shaded border to the titles, Word-processing 

guidelines and Word-processing tips. 

 Choose a colour of your choice. Centre align the text in both cases.

 Create a new document and write a short paragraph about something you are interested in.

 Now open the paragraph dialogue box and change the Spacing After to 0 pt. Observe the effect. Similarly 

change the Line spacing to different values and again observe the effect.

 Change the Indentation to First line indent 1.27 cm
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Using Tabs
Tabs are the final element we shall look at from the paragraph formatting dialogue box.

Tabs are used to accurately place text and numbers on lines. When using tabs it is usual to place the caret on the line

where you want the tabs to start, then Set them within the tab dialogue box. When all the tabs have been Set click 

OK to accept them

The tab positions will be carried over from one line to the next as you press enter. 

Alternatively, you can set tabs on a block of text by highlighting it and then setting the tabs. Of course, you will have 

to press the tab key appropriately in each line to achieve the effect you require.

The lines below are tabbed at 2 cm and 12 cm with the 12 cm tab also being centred and having the leader 2. 

 Reproduce these two pieces of work in a new document.

 Save the document as tabs.odt

First meeting .....................................................................June 2, 2001

Second meeting............................................................. January 25, 2002

Third Meeting.................................................................. March 3, 2002

Try the lines below with tabs at 2.5 cm (left aligned) and 12 cm (decimal aligned)

Biscuits..............................................................£.25
Pies..................................................................£7.00
Roast beef.....................................................£15.99

Space the lines better by choosing a paragraph spacing after of 6 pt.
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Page Formatting

Page Formatting Dialogue Box

Margins
Margins are the spaces around your body text. Normally this is 1.25 cm, top, bottom, left and right. There 

adjustment can be done from the Page Style dialogue box under the Page tab

 Create a new blank document

 Type a short paragraph on something that interests you and press the enter key (this gives you some text to 

play with)

Adjust, in turn each of the margins and observe the effect this has on your text

Orientation
Writer pages can be either Landscape or Portrait. There adjustment can be done from the Page Style dialogue box 

under the Page tab. These are changed by clicking Portrait or Landscape Orientation radio buttons.

 Change the orientation of your page to Landscape then back to Portrait

 Observe the effect this has on your text

Format
Generally the format of paper in Europe is A4. As you might guess this can be set to several different sizes but 

remember whatever size you set your paper to be you must have a printer capable of printing it.
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Page Breaks
Page breaks are useful if you want to start a new page without filling the one you are on. The simplest way to do this 

is with the keyboard short-cut Ctrl <enter> 

In the Insert Tab there are two tools that let you insert breaks, Page Break and Manual Break

Manual Break will allow you to insert a variety of breaks. Some will create a new page while others, Column break 

for instance, will not generate a new page (referred to as continuous breaks). 

Breaks

Section breaks are applied to quarantine a section of your document in order to apply changes that would otherwise 

affect the whole document. For example in this document some pages at the end are actually Landscape. To do this 

only for a page it was necessary to place a Section Break (Next Page) at the end of the last Portrait pages and again 

at the end of the last Landscape pages before applying the Landscape Orientation to pages to be changed.

Note: The Next Page type of Section Break had to be used because it is not possible to have Landscape and Portrait 

orientation on the same page at the same time. 
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Columns Tab
Writer starts off with single column format. This can be changed if required to two column, or even three column 

format. Changing the number of columns will affect the whole of the document unless Section Breaks (see previous) 

are first applied to mark off the section which is to be changed.
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Inserting Headers and Footers
Headers and footers are the pieces of text that appear on the top and bottom of each page of a document. 

Click the Header / Footer button on the insert drop-down menu. 

Examine the selection of standard headers that are available and choose one for your document.

Repeat the process but for the footer,

If all you want is page numbers then the Page Number button can be used to provide a set of page numbering 

options.

Once Headers and Footers have been inserted into a document they can be seen, albeit greyed out, on the top and 

the bottom of the document. To access the headers and footers of a page simply double-click on the header and 

footer area. To get back to the body text again, double-click in the body area.
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Hyphenation
By default Writer does not Hyphenate but it is possible to apply Automatic or Manual Hyphenation.

Automatic Hyphenation is turned on and off in the Format Paragraph dialogue box under the Text Flow tab 

Hyphenation Options

Hyphenated words that you want to stay hyphenated are placed by putting the cursor in the word and holding down 

Ctrl Shift -  (that's the minus sign after ctrl and shift). These are referred to as Non-breaking Hyphens.
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Adding Objects to Documents
This session we are going to focus on adding objects to Writer. An object is an element of word processing over and 

above normal text. Strictly even a character is an object. 

The feature to remember is that all objects have properties and these properties can be changed. For example, a 

picture is regarded as an object. Its properties are many, for example, its size, its border, its position and style. 

All these objects can be accessed using the Insert drop-down menu

Inserting Gallery Images and Media
To insert an image simply click on Image from the Insert drop-down. The Image dialogue box 

opens and you can browse to the image you want. 

If you want to insert some other media click on Media and 
choose from Gallery, Scan or Audio and Video

In the Gallery there are many items of clip-art to choose from. They are grouped in folders to help you locate the 

clip-art you want

To insert a clip-art select the image by right-clicking on it and selecting Insert.

Note the handles that appear around the image. These are used for resizing the image. 

If you click on the Insert > Media > Gallery a task pane appears on the right. This is the Gallery task pane. This allows

you to search for clip-art installed with LibreOffice

 Exercise 

 As in the example above search for a clip-art image that is in  the Environment folder and insert an image 

that you like into your document.

Once you have selected an image you will see the image handles appear in the corners and in the middle of the 

sides. You will also notice the image tools will be added to the Ribbon.

If you want to change the image in some way choose Format > Image > Properties.

As you will see, on the next few pages, there is a great deal you can do to change the image to suit your 

requirements.

Resizing a picture
Position the mouse over one of the handles until the pointer changes to a double-headed arrow
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 Drag the pointer to resize the picture

Position

 Use the Move fist to position the image is wherever you want it on the page

Size

 Set the Height and Width of your image using the Image dialogue box 

Format > Image > Properties then select the Type tab. If you want to keep the dimensions the same, (Aspect

ration), be sure to check the Keep ration box
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Inserting Shapes
As you will see from the there are many different shapes available.

Select the Insert Menu then select Shape then try any of the shape types . You will need to play with this feature to 

get to understand the huge variety there is here

Insert > Shape > Stars and Banners > Explosion

Would produce

Shapes have the same handles as other objects such as pictures and clip-art. However some have an additional 

yellow diamond adjustment handle that allows you to modify the shape in additional ways.

 Create a new document 

 From the Insert tab select Shapes and choose a Basic Shape, say a rounded rectangle.

 The cursor becomes a black cross. Use the left-hand mouse button to drag the cross to create the shape.

 Move and resize the shape with the move fist and the resize handles.

 Feeling adventurous? try rotating the shape 

There are three layers on your new page: the text layer, a layer below the text and a layer above the text. We will 

look at these layers later.

Formatting Shapes
Once you have inserted a shape you will notice  new Image Tools. This allows you to add many formatting features 

to your shapes.

Finally, add text by selecting the shape and simply typing.

Experiment on other shapes in your document.

Deleting Shapes
Select the shape and press the Delete (Del) key
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Layering Shapes
As you create objects they are added to the document a layer at a time. The successive objects are layered on top of 

the previous objects. You can bring these shapes forward or backward in layers

 From left to right Bring to Front Forward One Back One and Send to 

Back

Create three shapes similar to those below. Make sure they overlap each other.

Click on the shape covered by the others. In this case the square. 

click on the Bring Forward tool then select Bring to Front. This will

place the square to the front of the other two shapes. 

Note: You should be able to say which layer one of these 

shapes is in by looking at the overlaying. Layer one is the 

lowest layer

 Experiment with moving these shapes to the front and then progressively to the back

In the Image tool bar there are many buttons that provide you with the ability to rearrange the order of the objects 

as well as giving you the opportunity of determining the way text will flow around your objects. As you can 

see from the text and objects here you can produce some interesting effects. The Text Wrap style here is 

called Through which is why the text wraps the way it does. Tight 

would take the text away from the objects. It is well worth 

experimenting with the way different text wrap options work.

 Produce some text. A paragraph will do

 Insert into this text various objects and experiment with the way the text changes with the various wrap 

options.

Images in a Document
Type the list below into the text box on the left. (You could also type the text directly into the graphic itself.

afp://howard@Swansea.local/GKSS/GKSS Training/Writer/LibreOffice Writer ecdl course notes 1v4.odt
Page 29 of 49



GiaKonda Solar Schools

Save your work as H&S road map. 

Health and Safety Road Map

Decide who will help

Yourself

One or more of your workers

Someone from outside your business

Manage the risks in your business

How do I assess the risks in my workplace?

Don’t forget to consider everyone who could be harmed

Specific risks

Consult your employees

Health and safety and the work they do

How risks are controlled

The best ways of providing information and training

Provide training and information

Hazards and risks they may face

Measures in place to deal with those hazards and risks

How to follow any emergency procedures

Your finished work should look something like this (with the fourth box included!)

Note: Be careful not to choose a text colour the same as the background!
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Inserting Charts

Charting in Writer uses a cut down version of Calc. 

Select the Chart tool from the ribbon.

This will present you with a basic chart that can be modified to suit the data you have. 

Charts based on Calc can also be inserted into a Writer document. These are covered as part of the advanced course.
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Proofing Tools (Spelling and Grammar Checks Thesaurus)

Spelling Checks 
After you have entered a document, you should always check the spelling. Writer comes with a built-in spell checker 

to help with this. It can be found on the Review ribbon in the Proofing group

Writer checks spelling as you type by finding words in your document that do not 

match those in its dictionary. If automatic spell checking is turned on (which it is by 

default), incorrect words will be marked by wavy red underlining.

This is my documnt.

If you have any proofing errors (spelling or grammar) in your document, the status bar 

will show an open book with a red cross on it. Clicking on the button will

take you to the first error to correct it. This method is only useful for a

short document with few mistakes, as you have to correct each mistake

separately.

Writer also checks for:
Repeated words (e.g. to to)
Oddly capitalised words (tHE)
Proper names (e.g. swansea)

You can set additional options in the Spelling Dialog box.

Auto-correct and automatic spell checking
Some mistakes can be corrected automatically by Word. These include some common spelling errors.

Type in the word “documnt”. 

Right-click on the word (it will be underlined in red). A box will open up offering suggestions. Select the correct word 

from the list of suggestions.
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The Spelling and Grammar dialogue box
The Spelling and Grammar button launches the spelling and grammar dialogue box. It is found on the Review ribbon

in the Proofing group. Use this when you have a long document. To check the spelling of a specific word or phrase, 

select it first or the checker will check the whole document. 

You will find the Spelling and Grammar Option on the Review tab (the Proofing group).

 Click the Spelling and Grammar Button

OR

 Press F7

 The Spelling and Grammar dialog appears with the first misspelled word highlighted in red.

Word searches through your document matching each word against the words in its dictionary. It will highlight any 

words it does not recognise in the Not in Dictionary box. You have these options:

Change/Change All  If the correct spelling appears in the Suggestions box, select it and click Change. If there 

several occurrences of the same mistake, click Change All.

Ignore/Ignore All Choose this to leave the word or words unchanged.

Add Choose this option if you want to add the word to the dictionary. (Make sure it’s right!)

Autocorrect Click Autocorrect for Word to change it automatically in future. (Make sure that the correct 

spelling is selected in Suggestions box)

Exercise: Spelling

 Spell check the document spelling.odt

Grammar Check
You can use Writer grammar checker to help spot grammatical errors and suggest how to correct them.

As with the spell checker, you can choose to have Writer automatically check as you type. Any text it finds that does 

not follow certain grammatical rules is underlined with a wavy green line.

If you do not have automatic grammar checking on, you can still check the grammar by running a spell check and 

making sure that Check Grammar tick box is selected. Writer will check the spelling and then the grammar.

 To turn on automatic grammar checking you must open the File menu and select Options button 

 In the Writer Options select Proofing

 For automatic grammar checking, make sure Mark errors as you type is ticked

 Further options are available in the Settings button next to Writing Style
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Checking grammar is similar to checking spelling. The Options are:

Ignore Once Ignores the word or phrase.

Ignore Rule Skip all occurrences that break the same grammatical rule.

Next sentence Leaves the sentence as it is and move on.

Change Accept the change.

Explain Gives more information about the error. Word Help appears and describes the

grammar or style rule, giving suggestions for changing it.

Options Selects the different rules of grammar and style (the same as the Proofing 

Selections in Writer Options)

Undo Undoes the last correction.

If Writer is unable to offer a suggestion the button is greyed out. You can, however, still make changes by clicking 
into the dialogue box and editing the text and selecting the Change button.

Exercise: Grammar checker

 Grammar check the document SPELLING

Thesaurus
When you’re not sure of the meaning of a word, or when you think you’re using the same word too often, use the 

Word 2010 Thesaurus. It defines selected words and offers alternative words (synonyms).

It will also offer Opposites (antonyms).

The thesaurus is on the Review tab in the Proofing group.

 Open the document spelling.odt

 Move the cursor on to the word necessary. (You don’t have to select the word).

 In Review tab, click on Thesaurus.

 The Thesaurus pane appears with a list of alternative words.

 To choose an alternative, highlight the word you want in the task pane and click on the drop-down arrow 

that will appear.

 Click on Insert to replace your original word.

 To look up one of the alternatives and see its synonyms, select it and select Look Up or double-click on it.

 Try the thesaurus on other words in spelling.odt

You can also use your mouse to find a synonym. Point at a word and right-click.
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From the pop-up menu choose Synonyms (towards the bottom). You can also open the Thesaurus from this option.

Custom Dictionary
Words that are not recognised by the dictionary in Word can be added to the Custom Dictionary so that they are not

underlined in red.

There are two ways of doing this:

 Right-click in the middle of the word underlined in red and choose Add to Dictionary.

 Spell Check the document and when the word is located click the Add to Dictionary button.
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Tables
Tables are a very useful addition to word processing. It is an excellent way of setting out data without using the 

column and tab features. With Writer you can also use tables as simple spread-sheets. As with inserting most things 

in a document, Tables are found in the Insert drop-down. 

You  click on Insert Table to fill in the dialogue box with the details you required.
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 Once you have created the table add the headings in the first row as: 

 Title, First Name, Last Name, Address

You move between the cells of the table by pressing the tab key. You move back through the table by pressing the 

shift and tab keys. 

 Enter the details of five people into your table under the correct headings. 

You will notice as you reach the end of the forth person’s details pressing the tab key will create another row for 

you. This will help if you have to add more records to your table. 

Column width and row height
This requires you first click somewhere in the table so that the Table Tools tab appears as a new tab. At this point 

you must select the Layout tab directly below on the right. The Cell Size group will allow you to set the row height 

and the column width of any selected row or column.

Table tools tab
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Adding/Deleting Rows or Columns

Select any cell next to the place

you want to insert your row or column. In the Rows and Columns group click the appropriate icon to insert the row 

or column you want.  To delete a Row or Column simply select it and click the Delete icon from the Rows & Columns 

group on the Table ribbon. Note the Table ribbon only appears if a table is selected.

Merging Cells
Select the cells you want merge then click the Merge Cells icon in the Merge group

To un-merge the cells select the merged cells and click Split Cells in the Merge group

Deleting a table
To delete a table simply select it (Right click in the table and from the drop down menu click Select then on the 

choice menu click Table) then press the Delete (Del) key.

 Create a four by four table with the headings as shown

January February March

Daylight hours 8 hrs. 9 hrs. 11 hrs.

Rainfall 98.4 in 45.2 in 15.0

Temperature 6.6 (43.9) 6.9 (44.4) 9.3 (48.7)

 Add a row to the top of this data above the months. Select the whole of this top row of the table. Merge the 

cells in the top row. Type the heading UK Weather
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Mail Merge
Mail-merge is the process of sending multiple copies of one letter to different clients such that they each receive a 

personalised version.

Mail merge is a useful feature of LibreOffice Writer to create mass mailings. This feature allows you to insert data 

from external source like LibreOffice Calc or LibreOffice Base into the letter you are writing 

It involves two parts. First the letter itself (called the Form Letter) and second the individual records (called the Data 

Source) to be added to the letter. These two items are then merged to produce multiple personalised copies.

If we use the Form Letter

Dear <First Name> 

Thank you for attending our course on Programming with the Raspberry Pi. 

We hope you can continue to support us in the New Year when we will be running a course on LibreOffice.

Please pass on our good wishes to all in <School>.

And the Data Source

Brighton Savita Manchamvwa Inland Primary School
Cecilia Chomba Kariba Primary & Secondary
Clide Mulumba Kabuyu
Daniel Mangwende Dibwi
Fungai Moonze Kariba Primary & Secondary
Joan MwewaKabuyu Primary School
Kelvin Mudenda Sinadambwe Primary School
Kenny Farai Kazangarare Syamwiinga Primary School
Macloud Mwiinga Kabuyu Primary School
Nawiko Langowe Syamwiinga Primary School
Philemon Chikoondo Hachebozu

We would get letters of the sort

Dear Brighton 

Thank you for attending our course on Programming with the Raspberry Pi. 

We hope you can continue to support us in the New Year when we will be running a course on LibreOffice.

Please pass on our good wishes to all in Manchamvwa Inland Primary School.

For each record in the Data Source
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You want to create an invitation to attend a new course for your colleagues. Since you want to create an intimate 

invitation, you want to add every single name of the people you invite to the invitation letter. With mail merge, you 

don’t need to type all of the names of your prospective attendees one by one into your letter. Instead, you can 

create a database of your attendees using LibreOffice Calc or LibreOffice Base and import it using mail merge.

Here is how to use mail merge on LibreOffice Writer. In this example, we will be using LibreOffice Calc to create the 

attendee database. I have found this by far the easiest way to do this.

Create the guests database on LibreOffice (regular LibreOffice Calc file in ODS format). In this example, we will be 

adding the address of each attendees. Following is the example.

Brighton Savita Manchamvwa Inland Primary School

Cecilia Chomba Kariba Primary & Secondary

Clide Mulumba Kabuyu

Daniel Mangwende Dibwi

Fungai Moonze Kariba Primary & Secondary

Joan Mwewa Kabuyu Primary School

Kelvin Mudenda Sinadambwe Primary School

Kenny Farai Kazangarare Syamwiinga Primary School

Macloud Mwiinga Kabuyu Primary School

Nawiko Langowe Syamwiinga Primary School

Philemon Chikoondo Hachebozu

Save this as list of guests.ods. I usually save all my databases in the same place, in the Documents, Databases folder 

that I create. If you intend to do this create the folder you are going to use first.

Write your invitation letter using LibreOffice Writer 

Once done writing the letter template, go to Edit -> Exchange Database.

On the appearing window dialogue, click the 

Browse button and select the guest database (the 

LibreOffice Calc file) you have just created.
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Double-click the imported database. This will display the 

contained sheets. If your database file has multiple sheets, 

select the sheet that contains your attendees data and click 

the Define button.

Next, Go to View -> Data Source to view the entries of the database you have imported above. The database entries 

will be open right above your letter.

Click the column heading of the entries you want to add to the letter and drag it to the part of the letter you want.

Next, go to Tools -> Mail Merge Wizard.

On the Mail Merge Wizard, simply click the Next buttons until the Finish button. There is nothing that needs to be 

changed on this wizard.

The next step is up to you. Whether you want to print your letter or save it. If you want to save it, click the Saved 

Merged Documents button. To print it right away, click the Print Merged Documents button
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How to create labels with LibreOffice
If you intend to use commercial labels make a note of the Brand and Type of labels you intend to use.

Writer can be used to create labels from any data source though mailing labels are the most common. This is what 

we shall focus on.

Create a new document

You can use the wizard:

    select File  ▸ New  ▸ Labels;

    under the Labels tab, enter the text of the labels;

    select the brand and the type (Avery, etc.) or manually adjust the size of the labels on the Format tab;

    on the Options tab, choose if you want to print:

        a whole page of labels: select Entire page,

        only one label : select Single label and indicate the position of the label on the page;

    check Synchronize contents if you wish the labels to be all the same;

    select the printer with the Setup button;

    click on New document to generate the labels page;

    if you have checked Synchronize contents, format the first label (by modifying the layout, inserting pictures, etc.) 

and click on the Synchronize contents to past the formatting to all the labels on the page.
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Styles
Styles allow you to produce consistent high quality documents. They are essential for long documents with multiple 

headings and subheadings that require the generation of a quick and easy table of contents.
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Appendix1The Ribbons and Dialogue boxes

Home Ribbon 

The difference in layout that occurs with different size and resolution of screens can often lead to confusion. Be 

careful!
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Paragraph dialogue box
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Table Properties Tools 

Layout
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Page Style dialogue box
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Picture Tools tool-bar 
These tools appear whenever a image is selected
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